Updating the Firmware for New Clickers

Audience: Students and Teaching Assistants

This KB Article References: Clickers
This Information is Intended for: Students, Teaching Assistants
Last Updated: January 08, 2015
The firmware on clickers purchased since 2012 do not need to be updated.  The firmware only needs to be updated if you purchased your clicker prior to 2012.
 
If you're not sure when you purchased your clicker, you can check the firmware version on your clicker to see if it needs to be updated:
 
On your clicker, you will see a wrench on the lower right corner of the display.  Select it and press the right arrow key until you see "Device Info" and press Enter (Center button)... it will show a combination of characters, press the right arrow button again until you see "Firmware Version." If the version # is less than 2.0.5, you will need to update the firmware.

Additional Information


There are no additional resources available for this article.

Getting Help


The Division of Information Technology provides support on all of our services. If you require assistance please submit a support ticket through the IT Service Management system.

Submit A Ticket

Supported By


Academic Technology Services