Echo360 Viewing Requirements

This KB Article References: Echo360 Learning Capture
This Information is Intended for:
Last Updated: August 08, 2017

From a computer, Echo360 can be viewed using the most recent versions of:

  • Google Chrome
  • Mozilla Firefox
  • Safari
  • Internet Explorer (11 or higher)
  • Microsoft Edge

Web browsers require the latest version of Adobe Flash Player. By defaut, Google Chrome and Safari do not allow Adobe Flash Player to run, you must change your browser's permission to allow Adobe Flash to play. 

If you are using Echo360 from a mobile device, the Echo360 mobile app is available on iOS (9.1 or later) and Android (Jelly Bean or later).

Additional Information


There are no additional resources available for this article.

Getting Help


The Division of Information Technology provides support on all of our services. If you require assistance please submit a support ticket through the IT Service Management system.

Submit A Ticket

Supported By


Academic Technology Services