Symantec Endpoint Protection on a Mac

Audience: Faculty, Staff and Students

This KB Article References: Cyber Security
This Information is Intended for: Faculty, Staff, Students
Last Updated: March 22, 2017

Users with Mac OS X may download and install the latest version of Symantec Endpoint Protection from Softweb. Mac OS 10.7 and higher are supported by the latest version of Symantec Endpoint Protection (v12.1.5). Users with Mac OS 10.10 must use at least v12.1.5. 

Additional Information


There are no additional resources available for this article.

Getting Help


The Division of Information Technology provides support on all of our services. If you require assistance please submit a support ticket through the IT Service Management system.

Submit A Ticket

Supported By


Customer Engagement and Support